Búsqueda Binaria

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Proceso busqueda_binaria
 
Escribir ""	
Escribir "Introduzca n:"
Leer n
Dimension v(n)
 
Escribir ""
Para i <- 1 Hasta n Hacer
	Escribir i, ":"
	Leer v(i)
FinPara
 
Escribir ""
Escribir "Introduzca valor a buscar:"
Leer valor
 
inicio <- 1
fin <- n
valor_encontrado <- Falso
Mientras ( inicio <= fin ) y ( no valor_encontrado ) Hacer
	centro <- (inicio + fin) / 2
	Si v(centro) = valor 
	Entonces valor_encontrado <- Verdadero
	Sino Si v(centro) < valor 
	       Entonces inicio <- centro + 1
	       Sino fin <- centro -1
	       FinSi
	FinSi
FinMientras
 
Si valor_encontrado = Falso
Entonces Escribir "El valor ", valor, " no se ha localizado en el vector."
Sino Escribir "El valor ", valor, " ocupa la posicion ", centro, " en el vector."
FinSi
 
FinProceso

0 Respuestas a “Búsqueda Binaria”


  1. Ningún Comentario

Añade un Comentario