Ordenación por Intercambio Directo (burbuja)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Proceso ordenacion_intercambio
 
	// Solución válida para vectores de dos o más elementos
 
	Escribir ""
	Escribir "Longitud del vector: "
	Leer n
	Dimension v(n)
 
	Para i <- 1 Hasta n Hacer
		v(i) <- azar(100) + 1
	FinPara
 
	Para i <- n Hasta 2 Con Paso -1 Hacer
		Para j <- 1 Hasta i-1 Hacer
			Si v(j) > v(j+1) Entonces
				aux <- v(j)
				v(j) <- v(j+1)
				v(j+1) <- aux
			FinSi
		FinPara
	FinPara
 
	Escribir ""
	Escribir "Resultado:"
	Para i <- 1 Hasta n Hacer
		Escribir v(i)
	FinPara
 
FinProceso

0 Respuestas a “Ordenación por Intercambio Directo (burbuja)”


  1. Ningún Comentario

Añade un Comentario